Connectivity Issues

Incident Report for Unchained ISP

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 20:13 UTC

Monitoring

Our wholesale supplier have alerted us to issues at their Telehouse West PoP - circuits traversing this PoP may have seen a brief interruption to service around 19:30 this evening.

If you were one of the affected, please restart your router to allow it to route to us via one of the unaffected supplier PoPs. In the event this doesn't resolve your issue, please raise a support ticket with us and we'd be happy to investigate further.
Posted Nov 16, 2025 - 20:06 UTC
This incident affected: Broadband and Leased Lines.