Broadband network degraded

Incident Report for Unchained ISP

Resolved

This incident has been resolved.
Posted Nov 29, 2025 - 10:43 UTC

Investigating

Automated health check detected 17 reconnects in the last 30 minutes. This may indicate a wider broadband issue.
Posted Nov 29, 2025 - 04:25 UTC
This incident affected: Broadband.