Access to broadband control panel and client portal are currently down

Incident Report for Unchained ISP

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:00 UTC

Monitoring

Our broadband control panel and client portal are currently down due to a issue with Cloudflare who we use in front of our site.

Our connectivity services are not impacted.
Posted Nov 18, 2025 - 14:05 UTC
This incident affected: Client Portal and Broadband Portal.